Kotlin 1.2.50 发布,在 Eclipse IDE 插件中获支持

Kotlin 1.2.50 发布,在 Eclipse IDE 插件中获支持

达尔文
达尔文
发布于2018年06月14日
收藏 4

Kotlin 1.2.50 已发布,带来了一些 Bug 修复和工具更新。主要更新内容如下:

  • 在 Eclipse IDE 插件中更新 Kotlin 支持

  • 在标准库的常见部分和 JS 部分添加新功能

  • 将 JUnit 5 支持带给 kotlin.test

  • 改进了实验性脚本支持

  • 在 IntelliJ IDEA 中引入 Runnable Kotlin scratch 文件

  • 使用 Gradle 加速 kapt 并构建多模块 Android 项目

  • 使用二进制兼容模式更新实验 @JvmDefault 支持

  • 引入渐进式编译器模式

  • 修复了编译器和 IDE 插件中的许多已知问题,并提供了性能改进

完整更新内容请查看发布说明官方博客

此更新与 2017.2 至 2018.2 EAP 中的所有 IntelliJ IDEA 版本以及 Android Studio 3.0,3.1 和 3.2 Canary 兼容