技术成就梦想

Jenkins更新后出现uses deprecated protocols警告 原 Jenkins更新后出现uses deprecated protocols警告 aibinxiao



问题描述:

      昨天手贱将2.60.1(LTS)版本的Jekins升级到了2.90版本,升级后,出现如下警告:

      This Jenkins instance uses deprecated protocols: JNLP-connect,JNLP2-connect. It may impact stability of the instance. If newer protocol versions are supported by all system components (agents, CLI and other clients), it is highly recommended to disable the deprecated protocols. Protocol Configuration

     

      大概意思就是:

       这个Jenkins实例使用了废弃的协议:jnlp – connect,jnlp2 – connect。它可能影响实例的稳定性。如果所有系统组件(代理、CLI和其他客户端)都支持更新的协议版本,那么强烈建议禁用已弃用的协议。

      JNLP:JNLP(Java Network Launching Protocol )是java提供的一种可以通过浏览器直接执行java应用程序的途径,它使你可以直接通过一个网页上的url连接打开一个java应用程序。

解决方案:

      即禁用jnlp – connect,jnlp2 – connect即可,我们可以直接点击警告中的Protocol Configuration,或者点击系统管理—>全局安全配置—>Agents—>Agent protocols,然后取消勾选下面两项然后保存即可:

  • Java Web Start Agent Protocol/1 (deprecated, unencrypted)
  • Java Web Start Agent Protocol/2 (deprecated, unencrypted)

     

      完成后警告即可消失!

 

本文为原创文章,如果对你有一点点的帮助,别忘了点赞哦!比心!如需转载,请注明出处,谢谢!